You are not logged in.

#1 2014-04-17 02:58:06

correa.camilo
Guest
Registered: 2014-04-16
Posts: 4

Error running component and local metrics

Hi,

I receive the following error message "Error: -1" when I run the component and local metrics (The global metrics run fine). I have ran the metrics with Euclidean distance.

Below is the content log.

Apr 16, 2014 9:39:16 PM org.thema.graphab.MainFrame$31 run
SEVERE: null
java.lang.ArrayIndexOutOfBoundsException: -1
    at java.util.ArrayList.elementData(Unknown Source)
    at java.util.ArrayList.set(Unknown Source)
    at org.thema.drawshape.feature.DefaultFeature.setAttribute(DefaultFeature.java:106)
    at org.thema.graphab.MainFrame.calcCompIndice(MainFrame.java:1163)
    at org.thema.graphab.MainFrame$31.run(MainFrame.java:776)
    at java.lang.Thread.run(Unknown Source)

I hope you can help me with this doubt. Thanks

Camilo

Offline

#2 2014-04-17 12:03:32

admin
Graphab Dev
Registered: 2013-05-28
Posts: 25

Re: Error running component and local metrics

Hi,

I have found the bug for the component metrics calculation. I'll upload a new version soon. For local metrics, I cannot reproduce the same error, could you send me the error log for the local metric ?
Thanks
Gilles

Offline

#3 2014-04-19 17:57:01

correa.camilo
Guest
Registered: 2014-04-16
Posts: 4

Re: Error running component and local metrics

Hi,

thanks for the quick answer

I ran again the model with local metric and it worked fine, but the error -1 with metric component is recurrent

Below is the content log.

Apr 19, 2014 12:51:10 PM org.thema.graphab.MainFrame$31 run
SEVERE: null
java.lang.ArrayIndexOutOfBoundsException: -1
    at java.util.ArrayList.elementData(Unknown Source)
    at java.util.ArrayList.set(Unknown Source)
    at org.thema.drawshape.feature.DefaultFeature.setAttribute(DefaultFeature.java:106)
    at org.thema.graphab.MainFrame.calcCompIndice(MainFrame.java:1163)
    at org.thema.graphab.MainFrame$31.run(MainFrame.java:776)
    at java.lang.Thread.run(Unknown Source)

Thanks,

Camilo

Offline

#4 2014-04-23 15:26:14

admin
Graphab Dev
Registered: 2013-05-28
Posts: 25

Re: Error running component and local metrics

Hi,
I've updated Graphab version 1.2.1. The error for component metric calculations has been corrected.

Gilles

Offline

#5 2014-04-28 13:40:30

correa.camilo
Guest
Registered: 2014-04-16
Posts: 4

Re: Error running component and local metrics

I ran the model again and the metric component error has been fixed with this new release
Thank you
Best regards

Last edited by correa.camilo (2014-04-28 13:42:03)

Offline

Board footer